sábado, 15 de agosto de 2020

KDE Neon upgrade 20.04 Focal Fossa

KInfocentre do KDE Neon após upgrade para 20.04 Focal Fossa
KDE Neon após upgrade para 20.04 Focal Fossa

O upgrade do KDE Neon, da base Ubuntu 18.04 Bionic para 20.04 Focal Fossa, transcorreu sem qualquer problema, — e não introduziu nenhuma alteração no Plasma KDE, nem no Kernel. — Sob esses aspectos, é como se o KDE Neon permanecesse o mesmo de 2 semanas atrás:

2020-08-02                                                  2020-08-15

      Operating System: KDE neon 5.19                             Operating System: KDE neon 5.19
    KDE Plasma Version: 5.19.4                                  KDE Plasma Version: 5.19.4
KDE Frameworks Version: 5.72.0                              KDE Frameworks Version: 5.72.0
            Qt Version: 5.14.2                                          Qt Version: 5.14.2
        Kernel Version: 5.4.0-42-generic                            Kernel Version: 5.4.0-42-generic
...                                                         ...
    Graphics Processor: Mesa DRI Intel® UHD Graphics 630        Graphics Processor: Mesa Intel® UHD Graphics 630

 konsole 20.04.3                                             konsole 20.04.3
 dolphin 20.04.3                                             dolphin 20.04.3
    kate 20.04.3                                                kate 20.04.3
gwenview 20.04.3                                            gwenview 20.04.3

O Chromium (.deb) não foi removido, nem substituído pela versão .snap2. — Apenas, agora o apt / Synaptic o classifica como “obsoleto”, por não mais encontrá-lo nos repositórios. — No momento, tenho algum prazo para decidir o que vou fazer.

O repositório do GoogleEarth foi automaticamente desabilitado, ao iniciar o upgrade, — e bastou habilitá-lo de novo, depois. — O GoogleEarth continua funcionando normalmente.

Ainda não verifiquei o que mudou no Wine, — mas minha velha versão do Dreamweaver também continua funcionando como antes.

corona-cli finalmente encontra as dependências requeridas

Uma boa nova é que, agora, o corona-cli funciona, — o que antes não era possível.

O Gimp passou da versão 2.8 para 2.10, — mas para isso eu já estava preparado, desde o final de 2018. — Conforme o esperado, algumas configurações foram preservadas, e outras tive de refazer.

Upgrade


Verificando atualizações, no início da sessão do KDE Neon

Um requisito elementar, em distribuições Linux de versão fixa, é que a instalação deve estar atualizada, antes de se iniciar o upgrade para uma nova versão.

Em situações normais, verifico manualmente as atualizações pelo apt, depois aplico pelo Synaptic, — e é claro que eu já tinha feito isso, mais cedo. — Apenas tornei a verificar, por via das dúvidas, antes de iniciar o upgrade.

Última verificação de atualizações, antes de iniciar o upgrade do KDE Neon

Mas o site oficial do KDE Neon tem recomendações próprias, — tais como a de usar o Rosa Writer para “queimar” suas imagens ISO em Pendrive, — e a de usar o PackageKit (pkcon) para verificar e aplicar as atualizações.

Nunca encontrei uma explicação para essas idiossincrasias, — e nunca vi o pkcon discordar do apt / Synaptic, — afinal o PackageKit (tal como o Synaptic) é só uma interface amigável, que nas distros .deb usa o apt.

Em honra a esse ritual não-explicado, de bom grado executei um pkcon após o apt, — e é óbvio que ele não encontrou mais nada para atualizar.

Em seguida iniciei a execução do script, — que salva todas as saídas dos comandos em um arquivo “typescript”, na pasta do usuário:

$ history
...
  283  2020-08-13_20-49-06 date && sudo apt update && date
  284  2020-08-13_20-49-30 sudo pkcon refresh
  285  2020-08-13_20-52-27 script

Esse arquivo ~/typescript salvou nada menos que 62.972 linhas, — que resumo abaixo, com “...” para indicar as partes suprimidas, por serem muito extensas, ou repetitivas:

Script started on 2020-08-13 20:52:27-0300
...
$ date && sudo do-release-upgrade && date
Thu 13 Aug 20:52:32 -03 2020
...
Checking for a new Ubuntu release

0% [Working]
0% [Connecting to archive.neon.kde.org]
...
authenticate 'focal.tar.gz' against 'focal.tar.gz.gpg'
extracting 'focal.tar.gz'
...

Updating repository information

Third party sources disabled

Some third party entries in your sources.list were disabled. You can
re-enable them after the upgrade with the 'software-properties' tool
or your package manager.

To continue please press [ENTER]
...

100% [Working]                    218 kB/s 0s
Fetched 52.4 MB in 6s (218 kB/s)

Checking package manager
...

Reading state information... Done

Calculating the changes
...

Do you want to start the upgrade?

31 packages are going to be removed. 641 new packages are going to be
installed. 2132 packages are going to be upgraded.

You have to download a total of 2118 M. This download should take
about 1 hour 2 minutes with your connection.

Installing the upgrade can take several hours. Once the download has
finished, the process cannot be cancelled.

 Continue [yN]  Details [d] y

Fetching
...
0% [Working]
...
100% [Working]                     1329 kB/s 0s

Fetched 2118 MB in 6s (1329 kB/s)

Upgrading

Fetched 0 B in 0s (0 B/s)
  MarkInstall libc6:amd64 < 2.27-3ubuntu1.2 -> 2.31-0ubuntu9 @ii umU Ib > FU=1
  Installing libgcc-s1 as Depends of libc6
    MarkInstall libgcc-s1:amd64 < none -> 10-20200411-0ubuntu1 @un uN Ib > FU=0
    Installing gcc-10-base as Depends of libgcc-s1
      MarkInstall gcc-10-base:amd64 < none -> 10-20200411-0ubuntu1 @un uN > FU=0
  Installing libcrypt1 as Depends of libc6
    MarkInstall libcrypt1:amd64 < none -> 1:4.4.10-10ubuntu4 @un uN Ib > FU=0
      MarkInstall libc6:i386 < 2.27-3ubuntu1.2 -> 2.31-0ubuntu9 @ii umU Ib > FU=0
      Installing libgcc-s1 as Depends of libc6
        MarkInstall libgcc-s1:i386 < none -> 10-20200411-0ubuntu1 @un uN Ib > FU=0
        Installing gcc-10-base as Depends of libgcc-s1
          MarkInstall gcc-10-base:i386 < none -> 10-20200411-0ubuntu1 @un uN > FU=0
      Installing libcrypt1 as Depends of libc6
        MarkInstall libcrypt1:i386 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
        MarkInstall locales:amd64 < 2.27-3ubuntu1.2 -> 2.31-0ubuntu9 @ii umU Ib > FU=0
        Installing libc-bin as Depends of locales
          MarkInstall libc-bin:amd64 < 2.27-3ubuntu1.2 -> 2.31-0ubuntu9 @ii umU > FU=0
      new important dependency: libidn2-0:i386
      Installing libidn2-0 as Recommends of libc6
        MarkInstall libidn2-0:i386 < 2.0.4-1.1ubuntu0.2 -> 2.2.0-2 @ii umU Ib > FU=0
          MarkInstall libidn2-0:amd64 < 2.0.4-1.1ubuntu0.2 -> 2.2.0-2 @ii umU > FU=0
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) libc6-dev:amd64 < 2.27-3ubuntu1.2 -> 2.31-0ubuntu9 @ii umU Ib >
Broken libc6-dev:amd64 Depends on libcrypt-dev:amd64 < none | 1:4.4.10-10ubuntu4 @un uH >
  Considering libcrypt-dev:amd64 1 as a solution to libc6-dev:amd64 11
  MarkKeep libc6-dev:amd64 < 2.27-3ubuntu1.2 -> 2.31-0ubuntu9 @ii umU Ib > FU=0
  Re-Instated manpages-dev:amd64
  Re-Instated libcrypt-dev:amd64
  Re-Instated libc6-dev:amd64
Done

Upgrading

Fetched 0 B in 0s (0 B/s)
Preconfiguring packages ...
...
Selecting previously unselected package gcc-10-base:amd64.
(Reading database ...
(Reading database ... 5%
...
(Reading database ... 100%
(Reading database ... 240874 files and directories currently installed.)
Preparing to unpack .../gcc-10-base_10-20200411-0ubuntu1_amd64.deb ...
...
...
Preparing to unpack .../948-usb-modeswitch-data_20191128-3_all.deb ...
Unpacking usb-modeswitch-data (20191128-3) over (20170806-2) ...
Preparing to unpack .../949-youtube-dl_2020.03.24-1_all.deb ...
Unpacking youtube-dl (2020.03.24-1) over (2018.03.14-1ubuntu18.04.1) ...
Setting up libgme0:amd64 (0.6.2-1build1) ...
Setting up libmono-system-servicemodel-internals0.0-cil (6.8.0.105+dfsg-2) ...
Setting up libkf5codecs-data (5.72.0-0xneon+20.04+focal+build3) ...
Setting up libssh-gcrypt-4:amd64 (0.9.3-2ubuntu2.1) ...
Setting up libpwquality-common (1.4.2-1build1) ...
Installing new version of config file /etc/security/pwquality.conf ...
Setting up kdeplasma-addons-data (4:5.19.4-0xneon+20.04+focal+build7) ...
Setting up memtest86+ (5.01-3.1ubuntu1) ...
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/99_breeze-grub.cfg'
Generating grub configuration file ...
Found theme: /boot/grub/themes/breeze/theme.txt
Found linux image: /boot/vmlinuz-5.4.0-42-generic
Found initrd image: /boot/initrd.img-5.4.0-42-generic
Found linux image: /boot/vmlinuz-5.3.0-62-generic
Found initrd image: /boot/initrd.img-5.3.0-62-generic
Adding boot menu entry for EFI firmware configuration
done
Setting up arj (3.10.22-23) ...
Setting up cpio (2.13+dfsg-2) ...
Setting up libavc1394-0:amd64 (0.5.4-5) ...
Setting up powermgmt-base (1.36) ...
...
...
Setting up kwin-wayland (4:5.19.4-0xneon+20.04+focal+build7) ...
Setcap worked for /usr/bin/kwin_wayland!
Setting up plasma-workspace-wayland (4:5.19.4-0xneon+20.04+focal+build6) ...
Setting up kinfocenter (4:5.19.4-0xneon+20.04+focal+build7) ...
Setting up konq-plugins (4:20.04.3-0xneon+20.04+focal+build4) ...
Setting up sddm-theme-breeze (4:5.19.4-0xneon+20.04+focal+build6) ...
Setting up plasma-desktop (4:5.19.4-0xneon+20.04+focal+build6) ...
Setting up neon-desktop (4+p20.04+git20200803.1619) ...
Processing triggers for install-info (6.7.0.dfsg.2-5) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for libc-bin (2.31-0ubuntu9) ...
Processing triggers for systemd (245.4-4ubuntu3.2) ...
Processing triggers for ureadahead (0.100.0-21) ...
ureadahead will be reprofiled on next reboot
Processing triggers for ca-certificates (20190110ubuntu1.1) ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...

done.
Updating Mono key store
Mono Certificate Store Sync - version 6.8.0.105
Populate Mono certificate store from a concatenated list of certificates.
Copyright 2002, 2003 Motus Technologies. Copyright 2004-2008 Novell. BSD licensed.

Importing into legacy system store:
I already trust 135, your new list has 127
6 previously trusted certificates were removed.
Certificate removed: C=TR, L=Ankara, O=TÜRKTRUST Bilgi İletişim ve Bilişim Güvenliği Hizmetleri A.Ş., CN=TÜRKTRUST Elektronik Sertifika Hizmet Sağlayıcısı H5
Certificate removed: C=SE, O=AddTrust AB, OU=AddTrust External TTP Network, CN=AddTrust External CA Root
Certificate removed: C=US, O=VISA, OU=Visa International Service Association, CN=Visa eCommerce Root
Certificate removed: C=FR, O=Certplus, CN=Certplus Root CA G1
Certificate removed: C=FR, O=OpenTrust, CN=OpenTrust Root CA G2
Certificate removed: C=FR, O=OpenTrust, CN=OpenTrust Root CA G1
Import process completed.

Importing into BTLS system store:
I already trust 0, your new list has 127
Certificate added: ...
...
127 new root certificates were added to your trust store.
Import process completed.
Done
done.
Setting up mono-devel (6.8.0.105+dfsg-2) ...
...
Processing triggers for linux-image-5.4.0-42-generic (5.4.0-42.46) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-5.4.0-42-generic
I: The initramfs will attempt to resume from /dev/sdb14
I: (UUID=2ae5ec7d-42bd-4d6b-9597-7473984c75fe)
I: Set the RESUME variable to override this.
/etc/kernel/postinst.d/zz-update-grub:
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/99_breeze-grub.cfg'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found theme: /boot/grub/themes/breeze/theme.txt
Found linux image: /boot/vmlinuz-5.4.0-42-generic
Found initrd image: /boot/initrd.img-5.4.0-42-generic
Found linux image: /boot/vmlinuz-5.3.0-62-generic
Found initrd image: /boot/initrd.img-5.3.0-62-generic
Adding boot menu entry for UEFI Firmware Settings
done
Processing triggers for dictionaries-common (1.28.1) ...
aspell-autobuildhash: processing: en [en-common].
...
aspell-autobuildhash: processing: pt_BR [pt_BR].
Processing triggers for dbus (1.12.16-2ubuntu2.1) ...
Processing triggers for libvlc-bin:amd64 (3.0.9.2-1) ...
Processing triggers for initramfs-tools (0.136ubuntu6.2) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-42-generic
I: The initramfs will attempt to resume from /dev/sdb14
I: (UUID=2ae5ec7d-42bd-4d6b-9597-7473984c75fe)
I: Set the RESUME variable to override this.
Processing triggers for libgdk-pixbuf2.0-0:amd64 (2.40.0+dfsg-3) ...
Processing triggers for libgdk-pixbuf2.0-0:i386 (2.40.0+dfsg-3) ...
Processing triggers for wine (5.0-3ubuntu1) ...

Reading package lists... 0%
...
Reading package lists... 97%

Reading package lists... Done

Building dependency tree... 0%
...
Building dependency tree... 50%

Building dependency tree

Reading state information... 0%
...
Reading state information... Done

Searching for obsolete software

Reading state information... 0%
...
Reading state information... 99%

Reading state information... Done

Remove obsolete packages?

296 packages are going to be removed.

Removing the packages can take several hours.

 Continue [yN]  Details [d] d

Remove: diffuse dolphin4 komparator libkonqsidebarplugin4a xxdiff

Remove (was auto installed) command-not-found-data fonts-noto
  fonts-noto-cjk-extra fonts-noto-ui-extra fonts-noto-unhinted
  freepats fwupdate gcc-8-base:i386 gconf-service
  gconf-service-backend gconf2-common iputils-arping kde-runtime
  kde-runtime-data kdelibs-bin kdelibs5-data kdelibs5-plugins
...
  libreoffice-avmedia-backend-gstreamer libreoffice-librelogo
  libreoffice-ogltrans libreoffice-sdbc-hsqldb
...
  linux-headers-5.3.0-62 linux-headers-5.3.0-62-generic
  linux-headers-generic linux-headers-generic-hwe-18.04
  linux-hwe-5.4-headers-5.4.0-42 linux-image-5.3.0-62-generic
  linux-image-generic-hwe-18.04 linux-modules-5.3.0-62-generic
  linux-modules-extra-5.3.0-62-generic mlocate mono-jay
...
  python-webencodings python-zipp python3.6 python3.6-minimal qdbus
  qpdf qt-at-spi qtcore4-l10n qtdeclarative5-qtquick2-plugin
  rarian-compat ruby-did-you-mean ruby2.5 sextractor ureadahead
  xwayland-hwe-18.04

Continue [yN]  Details [d] y

Fetched 0 B in 0s (0 B/s)
(Reading database ...
(Reading database ... 5%
...
(Reading database ... 100%
(Reading database ... 287037 files and directories currently installed.)
Removing command-not-found-data (18.04.5) ...
Removing diffuse (0.4.8-3) ...
Removing dolphin4 (4:16.04.3-0ubuntu1) ...
...
Removing linux-image-5.3.0-62-generic (5.3.0-62.56~18.04.1) ...
I: /boot/vmlinuz.old is now a symlink to vmlinuz-5.4.0-42-generic
I: /boot/initrd.img.old is now a symlink to initrd.img-5.4.0-42-generic
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-5.3.0-62-generic
/etc/kernel/postrm.d/zz-update-grub:
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/99_breeze-grub.cfg'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found theme: /boot/grub/themes/breeze/theme.txt
Found linux image: /boot/vmlinuz-5.4.0-42-generic
Found initrd image: /boot/initrd.img-5.4.0-42-generic
Adding boot menu entry for UEFI Firmware Settings
done
Removing linux-image-generic-hwe-18.04 (5.4.0.42.46) ...
Removing linux-modules-5.3.0-62-generic (5.3.0-62.56~18.04.1) ...
Removing mlocate (0.26-3ubuntu3) ...
...
Removing libntrack0 (016-1.3) ...
Removing ntrack-module-libnl-0 (016-1.3) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for cups (2.3.1-9ubuntu1.1) ...
Processing triggers for libc-bin (2.31-0ubuntu9) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for libreoffice-common (1:6.4.4-0ubuntu0.20.04.1) ...
Processing triggers for dbus (1.12.16-2ubuntu2.1) ...
Processing triggers for shared-mime-info (1.15-1) ...
Processing triggers for sgml-base (1.29.1) ...
Processing triggers for fontconfig (2.13.1-2ubuntu3) ...
dpkg: warning: package not in status nor available database at line 1: command-not-found-data:amd64
dpkg: warning: package not in status nor available database at line 3: dolphin4:amd64
...
dpkg: warning: package not in status nor available database at line 295: xwayland-hwe-18.04:amd64
dpkg: warning: package not in status nor available database at line 296: xxdiff:amd64
dpkg: warning: found unknown packages; this might mean the available database
is outdated, and needs to be updated through a frontend method;
please see the FAQ 
(Reading database ...
(Reading database ... 5%
...
(Reading database ... 100%
(Reading database ... 220343 files and directories currently installed.)
Purging configuration files for linux-image-5.3.0-62-generic (5.3.0-62.56~18.04.1) ...
...
Purging configuration files for kde-runtime (4:17.08.3-0ubuntu1) ...
Processing triggers for dbus (1.12.16-2ubuntu2.1) ...

System upgrade is complete.

Restart required

To complete the upgrade, a system restart is required.
If you select 'y' the system will be restarted.

Continue [yN] n
Thu 13 Aug 23:31:19 -03 2020

$ exit

Script done on 2020-08-13 23:31:48-0300

Note que eu mantenho desabilitada a detecção de outras distros (os-probe), — por isso as sucessivas atualizações do Grub detectam apenas as versões de Kernel do próprio KDE Neon.

Teclar “d” para detalhar os arquivos que serão instalados, atualizados, removidos

Ao final de alguns minutos, fui informado de que o upgrade do KDE Neon implicaria em remover 31 pacotes (na verdade, foram 296), instalar 641 pacotes novos, atualizar 2.132 pacotes, — download total de uns 2 GiB, — e demoraria cerca de 1 hora, a julgar pela velocidade da conexão até aquele momento.

Infelizmente, eu tinha esquecido de uma precaução básica: — Desligar o Modem e tornar a ligar, após alguns minutos, para melhorar a conexão, que vem decaindo há alguns meses. — Um teste tardio, pelo speedtest-cli, mostrou que naquele momento eu não podia contar com mais do que 50 Mbit/s, do total de 200 “megas” contratados (26,3 MiB/s).

Mas isso, até o PTT / IX mais “próximo”, — pois ainda ia depender da velocidade dos repositórios no Brasil (br.archive.ubuntu) e no exterior (archive.neon.kde, security.ubuntu), assim como das velocidades encontradas no caminho entre meu provedor e os repositórios. — Na prática, o download começou com uma média de 3,7 MiB/s (máximo 5,3 MiB/s), para os pacotes do repositório do KDE Neon; mas logo decaiu para uma faixa de 100 a 500 KiB/s, para os pacotes do repositório Ubuntu no Brasil; e o processo todo acabou demorando mais de 2h 30min (20:52 ~ 23:31).

Capturas de tela falhadas, na fase final do upgrade do KDE Neon

A navegação no Chromium, a música local no VLC, o monitoramento pelo Conky e quase tudo mais continuou funcionando normalmente, durante todo esse tempo. — Apenas a Captura de tela (shortcut PrtScn + gnome-screenshot) deixou de funcionar por alguns minutos, entre 23:00 e 23:20; e o Dolphin e o Gwenview (abertos desde o início) não recuperaram o acesso às pastas, depois disso; mas o Kate continuou salvando as anotações, até o final.

xxxx

Para uma lista dos 296 pacotes removidos:


xxxx

— … ≠ • ≠ … —

PC desktop UEFI / GPT



Ferramentas &tc.



Debian's


Nenhum comentário:

Postar um comentário