sábado, 8 de outubro de 2016

Debian testing Stretch: falhas de atualização

Encerramento da última sessão do Debian testing “Stretch” instalado

A eliminação — pelo menos, temporária — do Debian testing “Stretch” era questão já decidida, aguardando apenas a melhor oportunidade, — embora com o propósito de instalar algum outro, — provavelmente Debian 8.6 KDE, lançado dias antes, em 16 Set. 2016.

Como “aprendizado”, — de um ponto de vista de mero usuário “leigo”, — não estava sendo muito útil, embora tenha sido bastante instrutivo “ver” um Kernel mais “avançado” (4.6) que os do Kubuntu 16.04, do Linux Mint 18 KDE e do KDE Neon, — mostrando que, por si só, isso pouco acrescenta.

Também não deixou de ser instrutivo “ver” em atividade um Debian ainda em construção, — bem como a confirmação de certas características específicas do Debian “puro”, — como o fato de que a montagem automática de partições adicionais pelas configurações do KDE não funciona, sendo necessário recorrer à edição — manual ou graficamente “ajudada” — do arquivo “/etc/fstab”.

Do ponto de vista “prático”, — ser uma alternativa funcional de trabalho, — apresentava lacunas ainda não superadas quanto ao Google Earth e ao Wine, — neste último, lacunas ainda por superar também no KDE Neon.

Permaneceu um mistério, — apesar de várias tentativas para decifrar, — a função do “httpredir”, aparente responsável pela reiterada procura de um repositório no Ministerio de Salud da pacata república de El Salvador, — eternamente indisponível; — e um “stretch-backports” que nunca tinha um “Release file” para oferecer.

Enfim, a ausência de vários pacotes e aplicativos ainda não desenvolvidos para o Debian testing “Stretch” ameaçava apresentar, sempre, algum incômodo adicional.

Também faltava — ainda falta, aliás, — compreender, do ponto de vista de mero usuário “leigo”, o “funcionamento” das “manipulações” das fontes de software (repositórios) que “transformam” um Debian “stable” em “unstable” ou “testing”, — coisa que, provavelmente, não seria possível (ou não traria qualquer potencial de “aprendizado”) a partir de um Debian que era, já, “testing”.

Daí, a ideia de substituí-lo, — ao menos durante algum tempo, — pelo Debian 8.6 KDE, — com o qual haviam sido feitos apenas alguns testes em “Live USB” (Debian 8.3, Debian 8.4), para tentar avançar alguns passos nesse ritual esotérico de “manipulação” de repositórios.

De qualquer modo, uma “retirada em boa ordem” incluiria um registro de todos os pacotes instalados, — bem como de todas as atualizações regulares, — a partir do Histórico do Synaptic, para qualquer exame posterior que viesse a ser necessário.

Infelizmente, a decisão de substituir o Debian testing “Stretch” acabou se precipitando, — e em circunstâncias que impossibilitaram o acesso ao Histórico do Synaptic, para essa documentação final.

  • Importante → Ver nota de 14 Out. 2016, em “Reiniciando o Debian testing Stretch”, mais à frente.

Resta, portanto, documentar o que for possível, dos últimos dias do Debian testing “Stretch” instalado, — em especial, as falhas e problemas que precipitaram sua remoção naquele momento.

Última atualização


Abstraindo as pequenas lacunas, falhas e mistérios, o Debian testing “Stretch” funcionou regularmente até 29 Set. 2016, quando foram feitas as últimas tentativas de deixar completo o Konqueror como gerenciador de arquivos, — coisa que não foi 100% possível por falta do pacote “kde-service-menu-fuseiso” nos repositórios, ao que parece.

No dia 30 Set. 2016, ainda carregou normalmente, e foi detectada a disponibilidade de uma grande atualização, incluindo a instalação do que parecia ser um Kernel 4.7.0, ou 4.7.5, ou 4.75-1, — vai saber.

flavio@Linux3:~$ sudo apt update  
[sudo] senha para flavio: 
Obter:1 http://ftp.br.debian.org/debian stretch InRelease [251 kB]
Obter:3 http://ftp.br.debian.org/debian stretch/non-free i386 Packages.diff/Index [27,8 kB]
Obter:4 http://ftp.br.debian.org/debian stretch/non-free amd64 Packages.diff/Index [27,8 kB]
Obter:5 http://ftp.br.debian.org/debian stretch/contrib i386 Packages.diff/Index [27,8 kB]
Obter:6 http://ftp.br.debian.org/debian stretch/contrib amd64 Packages.diff/Index [27,8 kB]
Obter:7 http://ftp.br.debian.org/debian stretch/contrib Translation-en.diff/Index [27,8 kB]
Obter:8 http://ftp.br.debian.org/debian stretch/main amd64 Packages.diff/Index [27,9 kB]
Obter:9 http://ftp.br.debian.org/debian stretch/main i386 Packages.diff/Index [27,9 kB]
Obter:10 http://ftp.br.debian.org/debian stretch/main Translation-en.diff/Index [27,9 kB]
Obter:11 http://ftp.br.debian.org/debian stretch/non-free i386 Packages 2016-09-29-1504.54.pdiff [285 B]
Obter:12 http://ftp.br.debian.org/debian stretch/non-free i386 Packages 2016-09-30-0309.44.pdiff [437 B]
Obter:13 http://ftp.br.debian.org/debian stretch/non-free amd64 Packages 2016-09-29-1504.54.pdiff [285 B]
Obter:14 http://ftp.br.debian.org/debian stretch/non-free amd64 Packages 2016-09-30-0309.44.pdiff [438 B]
Obter:15 http://ftp.br.debian.org/debian stretch/contrib i386 Packages 2016-09-29-1504.54.pdiff [550 B]
Obter:16 http://ftp.br.debian.org/debian stretch/contrib i386 Packages 2016-09-30-0309.44.pdiff [531 B]
Obter:17 http://ftp.br.debian.org/debian stretch/contrib amd64 Packages 2016-09-29-1504.54.pdiff [553 B]
Obter:18 http://ftp.br.debian.org/debian stretch/contrib amd64 Packages 2016-09-30-0309.44.pdiff [532 B]
Obter:19 http://ftp.br.debian.org/debian stretch/contrib Translation-en 2016-09-29-1504.54.pdiff [279 B]
Obter:20 http://ftp.br.debian.org/debian stretch/main amd64 Packages 2016-09-29-1504.54.pdiff [205 kB]
Obter:12 http://ftp.br.debian.org/debian stretch/non-free i386 Packages 2016-09-30-0309.44.pdiff [437 B]
Obter:18 http://ftp.br.debian.org/debian stretch/contrib amd64 Packages 2016-09-30-0309.44.pdiff [532 B]
Obter:14 http://ftp.br.debian.org/debian stretch/non-free amd64 Packages 2016-09-30-0309.44.pdiff [438 B]
Obter:16 http://ftp.br.debian.org/debian stretch/contrib i386 Packages 2016-09-30-0309.44.pdiff [531 B] 
Obter:19 http://ftp.br.debian.org/debian stretch/contrib Translation-en 2016-09-29-1504.54.pdiff [279 B] 
Obter:21 http://ftp.br.debian.org/debian stretch/main amd64 Packages 2016-09-30-0309.44.pdiff [27,3 kB]  
Obter:22 http://ftp.br.debian.org/debian stretch/main amd64 Packages 2016-09-30-1506.26.pdiff [63,0 kB]
Obter:23 http://ftp.br.debian.org/debian stretch/main i386 Packages 2016-09-29-1504.54.pdiff [200 kB]
Obter:22 http://ftp.br.debian.org/debian stretch/main amd64 Packages 2016-09-30-1506.26.pdiff [63,0 kB]
Obter:24 http://ftp.br.debian.org/debian stretch/main i386 Packages 2016-09-30-0309.44.pdiff [32,1 kB]  
Obter:25 http://ftp.br.debian.org/debian stretch/main i386 Packages 2016-09-30-1506.26.pdiff [63,0 kB]  
Obter:25 http://ftp.br.debian.org/debian stretch/main i386 Packages 2016-09-30-1506.26.pdiff [63,0 kB]
Obter:26 http://ftp.br.debian.org/debian stretch/main Translation-en 2016-09-29-1504.54.pdiff [816 B]
Obter:27 http://ftp.br.debian.org/debian stretch/main Translation-en 2016-09-30-0309.44.pdiff [9.250 B]  
Obter:28 http://ftp.br.debian.org/debian stretch/main Translation-en 2016-09-30-1506.26.pdiff [1.768 B]  
Obter:28 http://ftp.br.debian.org/debian stretch/main Translation-en 2016-09-30-1506.26.pdiff [1.768 B]  
Obter:29 http://ftp.br.debian.org/debian stretch/non-free amd64 DEP-11 Metadata [5.668 B]  
Obter:30 http://ftp.br.debian.org/debian stretch/contrib amd64 DEP-11 Metadata [7.716 B] 
Ign:2 http://ftp-nyc.osuosl.org/debian stretch-backports InRelease  
Obter:31 http://ftp.br.debian.org/debian stretch/main amd64 DEP-11 Metadata [2.776 kB] 
Err:32 http://ftp-nyc.osuosl.org/debian stretch-backports Release  
  404  Not Found 
Obter:33 http://ftp.br.debian.org/debian stretch/main DEP-11 64x64 Icons [6.043 kB]  
Obter:34 http://security.debian.org/debian-security stretch/updates InRelease [68,2 kB]  
Lendo listas de pacotes... Pronto kB/s 0ss 0ss 
E: The repository 'http://httpredir.debian.org/debian stretch-backports Release' does not have a Release file
N: Updating from such a repository can't be done securely, and is therefore disabled by default. 
N: See apt-secure(8) manpage for repository creation and user configuration details. 
flavio@Linux3:~$ apt list --upgradable
Listing... Pronto
at-spi2-core/testing 2.20.2-2 amd64 [upgradable from: 2.20.2-1]  
bsdutils/testing 1:2.28.2-1 amd64 [upgradable from: 1:2.28.1-1]  
cdebconf/testing 0.217 amd64 [upgradable from: 0.215]  
dirmngr/testing 2.1.15-3 amd64 [upgradable from: 2.1.11-7] 
e2fslibs/testing 1.43.3-1 amd64 [upgradable from: 1.43.1-1]  
e2fsprogs/testing 1.43.3-1 amd64 [upgradable from: 1.43.1-1] 
firefox-esr/testing 45.4.0esr-2 amd64 [upgradable from: 45.3.0esr-1] 
gir1.2-atk-1.0/testing 2.22.0-1 amd64 [upgradable from: 2.21.90-2] 
gir1.2-freedesktop/testing 1.50.0-1 amd64 [upgradable from: 1.49.1-2]  
gir1.2-gdkpixbuf-2.0/testing 2.36.0-1 amd64 [upgradable from: 2.34.0-1]  
gir1.2-glib-2.0/testing 1.50.0-1 amd64 [upgradable from: 1.49.1-2] 
gir1.2-gtk-2.0/testing 2.24.31-1 amd64 [upgradable from: 2.24.30-4]  
gir1.2-gtk-3.0/testing 3.22.0-1 amd64 [upgradable from: 3.21.5-3]  
gir1.2-pango-1.0/testing 1.40.3-2 amd64 [upgradable from: 1.40.2-1]  
gir1.2-vte-2.91/testing 0.46.0-1 amd64 [upgradable from: 0.45.90-2]  
gnupg/testing 2.1.15-3 amd64 [upgradable from: 1.4.20-6] 
gnupg-agent/testing 2.1.15-3 amd64 [upgradable from: 2.1.11-7] 
gnupg2/testing,testing 2.1.15-3 amd64 [upgradable from: 2.1.11-7]  
gpgv/testing 2.1.15-3 amd64 [upgradable from: 1.4.20-6]  
gtk-update-icon-cache/testing 3.22.0-1 amd64 [upgradable from: 3.21.5-3]
gtk2-engines-pixbuf/testing 2.24.31-1 amd64 [upgradable from: 2.24.30-4]
hdparm/testing 9.48+ds-2 amd64 [upgradable from: 9.48+ds-1]
imagemagick/testing 8:6.8.9.9-7.2+b1 amd64 [upgradable from: 8:6.8.9.9-7.2]
imagemagick-6.q16/testing 8:6.8.9.9-7.2+b1 amd64 [upgradable from: 8:6.8.9.9-7.2]
install-info/testing 6.3.0.dfsg.1-1+b1 amd64 [upgradable from: 6.3.0.dfsg.1-1]
isc-dhcp-client/testing 4.3.5~b1-1 amd64 [upgradable from: 4.3.4-1]
isc-dhcp-common/testing 4.3.5~b1-1 amd64 [upgradable from: 4.3.4-1]
libapparmor1/testing 2.10.95-4+b1 amd64 [upgradable from: 2.10.95-4]
libapt-pkg-perl/testing 0.1.29+b6 amd64 [upgradable from: 0.1.29+b5]
libatk1.0-0/testing 2.22.0-1 amd64 [upgradable from: 2.21.90-2]
libatk1.0-data/testing,testing 2.22.0-1 all [upgradable from: 2.21.90-2]
libatkmm-1.6-1v5/testing 2.24.2-2 amd64 [upgradable from: 2.24.2-1]
libatspi2.0-0/testing 2.20.2-2 amd64 [upgradable from: 2.20.2-1]
libblkid1/testing 2.28.2-1 amd64 [upgradable from: 2.28.1-1]
libc-bin/testing 2.24-3 amd64 [upgradable from: 2.23-5]
libc-l10n/testing,testing 2.24-3 all [upgradable from: 2.23-5]
libc6/testing 2.24-3 amd64 [upgradable from: 2.23-5]
libc6-i386/testing 2.24-3 amd64 [upgradable from: 2.23-5]
libcairo-perl/testing 1.106-1+b2 amd64 [upgradable from: 1.106-1+b1]
libclone-perl/testing 0.38-2+b1 amd64 [upgradable from: 0.38-2]
libcomerr2/testing 1.43.3-1 amd64 [upgradable from: 1.43.1-1]
libdebconfclient0/testing 0.217 amd64 [upgradable from: 0.215]
libdebian-installer4/testing 0.108 amd64 [upgradable from: 0.107]
libfcgi-perl/testing 0.78-1+b1 amd64 [upgradable from: 0.78-1]
libfdisk1/testing 2.28.2-1 amd64 [upgradable from: 2.28.1-1]
libffi6/testing 3.2.1-6 amd64 [upgradable from: 3.2.1-4]
libfile-fcntllock-perl/testing 0.22-3+b2 amd64 [upgradable from: 0.22-3+b1]
libgail-common/testing 2.24.31-1 amd64 [upgradable from: 2.24.30-4]
libgail18/testing 2.24.31-1 amd64 [upgradable from: 2.24.30-4]
libgdk-pixbuf2.0-0/testing 2.36.0-1 amd64 [upgradable from: 2.34.0-1]
libgdk-pixbuf2.0-common/testing,testing 2.36.0-1 all [upgradable from: 2.34.0-1]
libgirepository-1.0-1/testing 1.50.0-1 amd64 [upgradable from: 1.49.1-2]
libglib-perl/testing 3:1.321-1+b1 amd64 [upgradable from: 3:1.321-1]
libglib2.0-0/testing 2.50.0-1 amd64 [upgradable from: 2.49.6-1]
libglib2.0-bin/testing 2.50.0-1 amd64 [upgradable from: 2.49.6-1]
libglib2.0-data/testing,testing 2.50.0-1 all [upgradable from: 2.49.6-1]
libglibmm-2.4-1v5/testing 2.50.0-1 amd64 [upgradable from: 2.48.1-1]
libgps22/testing 3.16-3 amd64 [upgradable from: 3.16-2]
libgtk-3-0/testing 3.22.0-1 amd64 [upgradable from: 3.21.5-3]
libgtk-3-bin/testing 3.22.0-1 amd64 [upgradable from: 3.21.5-3]
libgtk-3-common/testing,testing 3.22.0-1 all [upgradable from: 3.21.5-3]
libgtk2-perl/testing 2:1.2498-3+b1 amd64 [upgradable from: 2:1.2498-3]
libgtk2.0-0/testing 2.24.31-1 amd64 [upgradable from: 2.24.30-4]
libgtk2.0-bin/testing 2.24.31-1 amd64 [upgradable from: 2.24.30-4]
libgtk2.0-common/testing,testing 2.24.31-1 all [upgradable from: 2.24.30-4]
libgtkmm-3.0-1v5/testing 3.22.0-1 amd64 [upgradable from: 3.20.1-1]
libhtml-parser-perl/testing 3.72-2+b1 amd64 [upgradable from: 3.72-2]
libimage-magick-q16-perl/testing 8:6.8.9.9-7.2+b1 amd64 [upgradable from: 8:6.8.9.9-7.2]
libinput-bin/testing 1.5.0-1 amd64 [upgradable from: 1.4.1-1]
libinput10/testing 1.5.0-1 amd64 [upgradable from: 1.4.1-1]
libio-pty-perl/testing 1:1.08-1.1+b2 amd64 [upgradable from: 1:1.08-1.1+b1]
libldap-2.4-2/testing 2.4.42+dfsg-2+b3 amd64 [upgradable from: 2.4.42+dfsg-2+b2]
liblist-moreutils-perl/testing 0.416-1+b1 amd64 [upgradable from: 0.416-1]
liblocale-gettext-perl/testing 1.07-3+b1 amd64 [upgradable from: 1.07-3]
libmagick++-6.q16-5v5/testing 8:6.8.9.9-7.2+b1 amd64 [upgradable from: 8:6.8.9.9-7.2]
libmagickcore-6.q16-2/testing 8:6.8.9.9-7.2+b1 amd64 [upgradable from: 8:6.8.9.9-7.2]
libmagickcore-6.q16-2-extra/testing 8:6.8.9.9-7.2+b1 amd64 [upgradable from: 8:6.8.9.9-7.2]
libmagickwand-6.q16-2/testing 8:6.8.9.9-7.2+b1 amd64 [upgradable from: 8:6.8.9.9-7.2]
libmount1/testing 2.28.2-1 amd64 [upgradable from: 2.28.1-1]
libncurses5/testing 6.0+20160917-1 amd64 [upgradable from: 6.0+20160625-1]
libncursesw5/testing 6.0+20160917-1 amd64 [upgradable from: 6.0+20160625-1]
libnet-dbus-perl/testing 1.1.0-4+b1 amd64 [upgradable from: 1.1.0-4]
libnet-ssleay-perl/testing 1.77-1+b1 amd64 [upgradable from: 1.77-1]
libnss3/testing 2:3.26-2 amd64 [upgradable from: 2:3.25-1]
libpango-1.0-0/testing 1.40.3-2 amd64 [upgradable from: 1.40.2-1]
libpango-perl/testing 1.227-1+b1 amd64 [upgradable from: 1.227-1]
libpangocairo-1.0-0/testing 1.40.3-2 amd64 [upgradable from: 1.40.2-1]
libpangoft2-1.0-0/testing 1.40.3-2 amd64 [upgradable from: 1.40.2-1]
libpangoxft-1.0-0/testing 1.40.3-2 amd64 [upgradable from: 1.40.2-1]
libperlio-gzip-perl/testing 0.19-1+b2 amd64 [upgradable from: 0.19-1+b1]
libpixman-1-0/testing 0.34.0-1 amd64 [upgradable from: 0.33.6-1]
libpng16-16/testing 1.6.25-1 amd64 [upgradable from: 1.6.24-2]
libpq5/testing 9.6~rc1-1+b1 amd64 [upgradable from: 9.6~rc1-1]
libresid-builder0c2a/testing 2.1.1-15 amd64 [upgradable from: 2.1.1-14]
libsidplay2/testing 2.1.1-15 amd64 [upgradable from: 2.1.1-14]
libsmartcols1/testing 2.28.2-1 amd64 [upgradable from: 2.28.1-1]
libsnmp30/testing 5.7.3+dfsg-1.5+b1 amd64 [upgradable from: 5.7.3+dfsg-1.5]
libsocket6-perl/testing 0.27-1+b1 amd64 [upgradable from: 0.27-1]
libss2/testing 1.43.3-1 amd64 [upgradable from: 1.43.1-1]
libssl1.0.2/testing 1.0.2j-1 amd64 [upgradable from: 1.0.2h-1]
libsub-name-perl/testing 0.19-1+b1 amd64 [upgradable from: 0.19-1]
libtext-charwidth-perl/testing 0.04-7+b5 amd64 [upgradable from: 0.04-7+b4]
libtext-iconv-perl/testing 1.7-5+b4 amd64 [upgradable from: 1.7-5+b3]
libtinfo5/testing 6.0+20160917-1 amd64 [upgradable from: 6.0+20160625-1]
libuuid1/testing 2.28.2-1 amd64 [upgradable from: 2.28.1-1]
libvte-2.91-0/testing 0.46.0-1 amd64 [upgradable from: 0.45.90-2]
libvte-2.91-common/testing,testing 0.46.0-1 all [upgradable from: 0.45.90-2]
libwacom-bin/testing 0.22-1 amd64 [upgradable from: 0.19-1]
libwacom-common/testing,testing 0.22-1 all [upgradable from: 0.19-1]
libwacom2/testing 0.22-1 amd64 [upgradable from: 0.19-1]
libxcb-composite0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-damage0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-dpms0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-dri2-0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-dri3-0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-glx0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-present0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-randr0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-record0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-render0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-shape0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-shm0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-sync1/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-xfixes0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-xinerama0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-xkb1/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb-xv0/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxcb1/testing 1.12-1 amd64 [upgradable from: 1.11.1-1.1]
libxfont1/testing 1:1.5.2-1 amd64 [upgradable from: 1:1.5.1-1]
libxml-parser-perl/testing 2.44-2+b1 amd64 [upgradable from: 2.44-2]
libxmmsclient6/testing 0.8+dfsg-16+b1 amd64 [upgradable from: 0.8+dfsg-16]
libyaml-libyaml-perl/testing 0.63-1+b1 amd64 [upgradable from: 0.63-1]
libzbar0/testing 0.10+doc-10+b2 amd64 [upgradable from: 0.10+doc-10+b1]
linux-image-amd64/testing 4.7+75 amd64 [upgradable from: 4.6+74]
locales/testing,testing 2.24-3 all [upgradable from: 2.23-5]
mount/testing 2.28.2-1 amd64 [upgradable from: 2.28.1-1]
multiarch-support/testing 2.24-3 amd64 [upgradable from: 2.23-5]
nano/testing 2.7.0-1 amd64 [upgradable from: 2.6.3-1]
ncurses-base/testing,testing 6.0+20160917-1 all [upgradable from: 6.0+20160625-1]
ncurses-bin/testing 6.0+20160917-1 amd64 [upgradable from: 6.0+20160625-1]
ncurses-term/testing,testing 6.0+20160917-1 all [upgradable from: 6.0+20160625-1]
openssl/testing 1.0.2j-1 amd64 [upgradable from: 1.0.2h-1]
perl/testing 5.24.1~rc3-3 amd64 [upgradable from: 5.22.2-5]
perl-base/testing 5.24.1~rc3-3 amd64 [upgradable from: 5.22.2-5]
printer-driver-dymo/testing 1.4.0-6 amd64 [upgradable from: 1.4.0-5]
printer-driver-ptouch/testing 1.4.2-2 amd64 [upgradable from: 1.4.2-1]
util-linux/testing 2.28.2-1 amd64 [upgradable from: 2.28.1-1]
util-linux-locales/testing,testing 2.28.2-1 all [upgradable from: 2.28.1-1]
uuid-runtime/testing 2.28.2-1 amd64 [upgradable from: 2.28.1-1]
vim-common/testing,testing 2:8.0.0003-1 amd64 [upgradable from: 2:7.4.1829-1]
vim-tiny/testing 2:8.0.0003-1+b1 amd64 [upgradable from: 2:7.4.1829-1]
wpasupplicant/testing 2.5-2+v2.4-3 amd64 [upgradable from: 2.5-2+v2.4-2]
xkb-data/testing,testing 2.18-1 all [upgradable from: 2.17-1]
xserver-common/testing,testing 2:1.18.4-2 all [upgradable from: 2:1.18.4-1]
xserver-xorg-core/testing 2:1.18.4-2 amd64 [upgradable from: 2:1.18.4-1]
xserver-xorg-input-evdev/testing 1:2.10.3-1 amd64 [upgradable from: 1:2.10.2-1]
xserver-xorg-input-libinput/testing 0.19.1-1 amd64 [upgradable from: 0.19.0-1]
xserver-xorg-video-nouveau/testing 1:1.0.13-1 amd64 [upgradable from: 1:1.0.12-2]
xwayland/testing 2:1.18.4-2 amd64 [upgradable from: 2:1.18.4-1]

Pela primeira vez (acho), não foi buscado o Ministerio de Salud de El Salvador, — mas um outro mirror (talvez da pacata cidade de New York City), igualmente fora do ar.

Rodados esses comandos “apt update” e “apt list --upgradable”, — hábito recente, para melhor observar o comportamento de repositórios e documentar algumas atualizações mais interessantes, — foi aberto o Synaptic, para aplicar as mudanças.

Pacotes removidos e instalados com a última atualização do Debian testing “Stretch” pelo Synaptic

Muitas vezes, o Synaptic acaba oferecendo uma visão mais completa, — incluindo pacotes a serem removidos / instalados, — como neste caso.

A janela de saída dos comandos automáticos de desempacotamento, configuração etc. também costuma apresentar algumas indicações de interesse, que foram devidamente copiadas, para documentação.

“Possible missing firmware” ao atualizar o Debian testing “Stretch”, segundo o Synaptic

Ao que tudo indica, as coisas começaram a fugir do script, durante a “aplicação” das alterações, quando chegou a hora de configurar o libgdk-pixbuf2.0-common (2.36.0-1):

Configurando libgdk-pixbuf2.0-common (2.36.0-1) ...
A processar 'triggers' para cups (2.2.0-2) ...
GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': Arquivo ou diretório não encontrado

This likely means that your installation is broken.
Try running the command
  gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being. at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 132.
debconf: incapaz de inicializar interface: Gnome
debconf: (Não foi possível reconhecer o formato de imagem do arquivo "/usr/share/pixmaps/debian-logo.png" at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 132.)
debconf: tentando com interface: Dialog
debconf: incapaz de inicializar interface: Dialog
debconf: (A variável TERM não está definida, então a interface dialog não é utilizável.)
debconf: tentando com interface: Readline
Updating PPD files for ptouch ...
Configurando linux-image-4.7.0-1-amd64 (4.7.5-1) ...
I: /vmlinuz is now a symlink to boot/vmlinuz-4.7.0-1-amd64
I: /initrd.img is now a symlink to boot/initrd.img-4.7.0-1-amd64
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.7.0-1-amd64
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
cp: impossível obter estado de '/etc/modprobe.d/*': Arquivo ou diretório não encontrado
/etc/kernel/postinst.d/zz-update-grub:
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Imagem Linux encontrada: /boot/vmlinuz-4.7.0-1-amd64
Imagem initrd encontrada: /boot/initrd.img-4.7.0-1-amd64
Imagem Linux encontrada: /boot/vmlinuz-4.6.0-1-amd64
Imagem initrd encontrada: /boot/initrd.img-4.6.0-1-amd64
Encontrado KDE neon User Edition 5.7 (16.04) em /dev/sda1
Encontrado Ubuntu 16.04.1 LTS (16.04) em /dev/sdb1
Encontrado Linux Mint 18 Sarah (18) em /dev/sdb6
concluído
A processar 'triggers' para initramfs-tools (0.125) ...
update-initramfs: Generating /boot/initrd.img-4.7.0-1-amd64
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
cp: impossível obter estado de '/etc/modprobe.d/*': Arquivo ou diretório não encontrado

Infelizmente, faltou aproveitar a ocasião para copiar logo, do Histórico, as alterações desse dia, — bem como as anteriores, — e depois disso o Synaptic, simplesmente, nunca mais abriu outra vez.

Reiniciando o Debian testing “Stretch”


Falha do Xsensors após a última atualização do Debian testing “Stretch”

Reiniciado o Debian testing “Stretch”, a primeira constatação foi de falha do Xsensors.

Indicações do KInfocenter após a última atualização do Debian testing “Stretch”

O KInfocenter e o Conky também não indicaram qualquer alteração do Kernel, — isso, porém, não foi grande surpresa, pois no Debian essas “atualizações” são diferentes do padrão observado no Ubuntu e derivados.

19 Jun 2016 (17:11) → linux-image-amd64 (4.5+73) to 4.6+74
19 Jun 2016 (17:11) → linux-image-4.6.0-1-amd64 (4.6.1-1)
28 Jun 2016 (12:41) → linux-image-4.6.0-1-amd64 (4.6.1-1) to 4.6.2-2
12 Jul 2016 (08:39) → linux-image-4.6.0-1-amd64 (4.6.2-2) to 4.6.3-1
24 Jul 2016 (12:41) → linux-image-4.6.0-1-amd64 (4.6.3-1) to 4.6.4-1

  • 14 Out. 2016 - Foi cometido um possível erro, nesse ponto: — Era necessário atualizar o Grub do Kubuntu, — que controla o Menu de inicialização, — para reconhecer e incluir o novo Kernel do Debian testing “Stretch”, se fosse o caso. — Por via das dúvidas, foi feito um “Teste de memória com o Memtest86”.

Redução (manual?) do número de Mirrors e revezamento na categoria “404 Not found”

Novo exame mostrou que, — embora o Xsensors permanecesse fora de combate, — as informações de Temperatura etc. estavam, sim, disponíveis, e no mesmo “lugar” de sempre.

Revezamento de Mirrors na categoria “404 Not found”

Mais algumas tentativas no “sudo apt update”, — com o Ministerio de Salud e o “cc.lehigh.edu” revezando-se na categoria “404 Not found”, — sugeriram um encolhimento do número de Mirrors consultados (talvez por alguma tentativa manual?).

Àquela altura, já estavam baixadas as ISOs do Debian 8.6 KDE e do Kubuntu 16.10 Beta2, — esta última, já testada desde a véspera, — e aguardando ansiosamente uma “vaga”, entre as 4 distribuições Linux instaladas no computador.

Por isso, não havia grande entusiasmo em continuar tentando “entender” (e consertar) essa falha do Debian testing “Stretch”, — coisas, aliás, pouco promissoras.

Substituição


  • Em 30 Set. 2016, foi tentada, — duas vezes, sem sucesso, — a instalação do Kubuntu 16.10 Beta2


— … ≠ • ≠ … —

Debian


Nenhum comentário:

Postar um comentário